supermemory/apps/web/package.json
Cursor Agent c7cac0f226
fix(deps): bump apps/web next to ^16.3.3 and @opennextjs/cloudflare to ^1.20.6
Clears the two critical Next.js RCE advisories (GHSA-p293-qw3h-jr36 /
CVE-2026-75604 and GHSA-2xp9-vwfh-vxw4) for the production web app.

apps/web pinned next ^16.0.11, which the root lock resolved to next@16.1.6
- inside the vulnerable range (>=16.0.0,<16.3.3) both advisories name. Bump
the pin to ^16.3.3 (resolves to next@16.3.4, above both first_patched_version
thresholds) and move the OpenNext Cloudflare adapter to ^1.20.6, whose peer
range accepts next >=16.3.3.

Co-authored-by: Dhravya Shah <dhravya@supermemory.com>
2026-09-10 02:19:49 +00:00

40 lines
1.1 KiB
JSON

{
"name": "@repo/web",
"version": "0.1.0",
"private": true,
"portless": {
"name": "app.dev.supermemory",
"script": "dev:app"
},
"scripts": {
"dev": "portless",
"dev:app": "next dev --port ${PORT:-3000}",
"build": "next build",
"check-types": "tsc --noEmit",
"start": "next start",
"lint": "biome check --write",
"preview": "opennextjs-cloudflare build && opennextjs-cloudflare preview",
"deploy": "opennextjs-cloudflare build && opennextjs-cloudflare deploy",
"upload": "opennextjs-cloudflare build && opennextjs-cloudflare upload",
"cf-typegen": "wrangler types --env-interface CloudflareEnv cloudflare-env.d.ts"
},
"dependencies": {
"@opennextjs/cloudflare": "^1.20.6",
"next": "^16.3.3",
"react": "^19.2.4",
"react-dom": "^19.2.4"
},
"devDependencies": {
"@biomejs/biome": "^2.2.2",
"@total-typescript/tsconfig": "^1.0.4",
"@types/node": "^24.0.4",
"@types/react": "^19.2.9",
"@types/react-dom": "^19.2.3",
"typescript": "^5.8.3",
"wrangler": "^4.26.0"
},
"overrides": {
"@types/react": "^19.2.9",
"@types/react-dom": "^19.2.3"
}
}